WorkerSafety Pro AWS Disruption

Incident Report for Becklar Workforce Safety

Postmortem

Amazon Web Services experienced a wide disruption today affecting many companies and industries.

The AWS disruption affected Becklar’s ability to:

  1. Sign in to the WorkerSafety Pro app and Safety Portal
  2. Generate alarms
  3. Send emergency notifications

AWS steadily improved service throughout the day and all of our automated tests began passing normally. While AWS continued to report disruptions to other services in other industries, they no longer appeared to affect Becklar WorkforceSafety.

Once our tests passed successfully for a period of one hour, we resolved this incident.

Posted Oct 20, 2025 - 20:30 UTC

Resolved

The AWS disruption appears to be resolved for Becklar Workforce Safety and services are working normally. While AWS is still reporting disruptions, these do not appear to be affecting Becklar at this time. We will continue to monitor for any residual issues.
Posted Oct 20, 2025 - 20:10 UTC

Monitoring

AWS has steadily increased availability of its services. We have tested WorkerSafety Pro and alarm notifications successfully. We are still monitoring for intermittent issues.
Posted Oct 20, 2025 - 19:16 UTC

Identified

We continue to experience service disruptions due to the AWS update affecting the US-1 Region. While recovery is underway and many systems are operational, full restoration is still in progress. Key services impacted include automated voice calls with varying degrees of recovery.
Posted Oct 20, 2025 - 17:49 UTC

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 17:48 UTC

Update

We continue to experience service disruptions due to the AWS update affecting the US-1 Region. While recovery is underway and many systems are operational, full restoration is still in progress. Key services impacted include automated voice calls with varying degrees of recovery.
Posted Oct 20, 2025 - 17:38 UTC

Update

This issue is confirmed to be related to an Amazon Web Services outage which began affecting our services at 8:36am MT. We are awaiting AWS to resolve this widespread issue and will continue to post updates.
Posted Oct 20, 2025 - 16:27 UTC

Investigating

We are currently investigating an issue possibly related to the Amazon Web Services disruption. We will provide updates as soon as we have more information.
Posted Oct 20, 2025 - 15:41 UTC
This incident affected: Workforce Safety API, Workforce Safety Portal, and Workforce Safety Single Sign-On (SSO) Service.