Engage/AVA Outage

Incident Report for Becklar Workforce Safety

Resolved

This incident has been resolved.
Posted Jun 04, 2025 - 20:03 UTC

Update

Our investigation has shown that the system has been operational since this morning as previously noted.
Posted Jun 04, 2025 - 17:34 UTC

Update

We are continuing to investigate this issue.
Posted Jun 04, 2025 - 16:39 UTC

Investigating

Engage experienced another outage today which was resolved by 6:40am MT. Customers utilizing our monitoring center would automatically be contacted by an operator and not be affected. We are continuing to investigate reports of possible intermittent failures.
Posted Jun 04, 2025 - 16:38 UTC
This incident affected: Engage Platform (Automated Voice).